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About calendars
Your personal FirstClass calendar is like a personal diary. It records calendar events and tasks.
Unlike your personal diary, you can permit other people to view and update your FirstClass calendar. This allows everyone to schedule meetings at mutually convenient times.
FirstClass calendars work much like conferences; your administrator may create public calendars and give you access to them, or you can create your own calendars and give others access to them.
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Types of calendars
FirstClass supports the following types of calendars:
•	personal calendar
This is your own calendar. You can limit others' access to your personal calendar by updating your calendar permissions, just as you would update the permissions of a calendar that you created.
•	group calendar
A public calendar that lets a specific group of people coordinate their time and tasks.
•	resource calendar
A public calendar that represents a specific resource, such as a projector. A resource calendar is updated when users book the resource as part of creating a calendar event.
•	location calendar
A public calendar that represents a specific resource, such as a meeting room. Location calendars are updated just like resource calendars.
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Opening calendars
To open your personal calendar, choose File > Open > Calendar.
To open another user's calendar, open the shortcut menu from the user in the Directory, Who's Online list, message envelopes, or chat windows, then choose Open User Calendar.
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Calendar views
You can look at a calendar using the same views as you use for conferences. While in these views, you can do the same things you do with messages. For example, in List view you can sort calendar events.
In addition, there are the following specialized calendar views:
•	month (shows the least detail) - choose View > View by Month
The current day is highlighted.
•	week - choose View > View by Week.
The current day is highlighted.
•	day (shows the most detail) - choose View > View by Day
•	Today list - choose View > View Today List.
Shows events that take place today and tasks that start today or are still ongoing.
You can select the view you want for each pane of the calendar.
Calendar navigation
The navigation buttons in the special calendar views let you scroll backward and forward through calendar pages. You can also return to the current month, week, or day, or go to the page containing a specific date.
To go to the page containing a specific date, click this button to open a popup calendar:
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In the popup calendar, click the double arrow buttons to scroll years, or the single arrow buttons to scroll months. To select a date, click it, then click OK. To select today, click Today.
To open the first unread item, choose Collaborate > Navigation > Next Unread.
Customizing calendar views
You can customize your calendar views in the following ways:
•	display week numbers (month and week views)
•	change the day on which the week starts (month view).
To customize your calendar views, make the changes you want in your calendaring preferences.
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Printing calendars
To print a calendar immediately, using your print layout defaults, click the Print toolbar button. The active pane is printed in the current view.
If you choose File > Print, the Print Layout form opens, allowing you to specify the dates and view you want to print.
Note
Any changes that you make on the Print Layout form are not saved as defaults when you open this form using File > Print.
Top
Calendar reminders
When you create a calendar event or task, you can tell FirstClass to generate a reminder at the time you specify. The reminder appears as a dialog box if you are logged into a server. This dialog box contains a Details button that opens the event or task details when clicked.
If you are not logged into a server, the reminder is sent to your Mailbox as a message.
Forwarding calendar reminders to pagers
FirstClass can notify you of calendar reminders through your pager, if you have an email-enabled paging system.
To forward calendar reminders to your pager, update your paging preferences. Choose Yes or Urgent Only at "Calendar items".
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Calendar events
Adding calendar events
To add an event to a calendar:
1	Open the calendar.
2	Choose File > New > New Event.
Shortcuts
To create an event that starts on a particular day, double-click either the blank space under the day you want or on the date itself, or open the shortcut menu from the day, then choose New Event.
3	Update the basic event information.
The default start time and duration are based on values in your calendaring preferences. FirstClass looks for a free time slot within your normal work day (as defined by your preferences).
4	Update the Scheduling tab to invite participants, book resources, and check that there are no conflicts.
If there are conflicts, you can reschedule the event using this tab.
5	Update the Repeat tab, if you want the event to show up repeatedly on the calendar.
If you make the event repeat, this icon is displayed beside the event:
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6	Update the Reminders tab, if you want to generate reminders.
If you add reminders to the event, this icon is displayed beside the event:
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7	Attach files or add content just as you would for a message, if necessary.
8	Choose Message > Priority > Priority Urgent, if you want to make the event urgent.
The event will appear in bold on calendars.
The event is added to your calendar when you close the calendar event form. If a participant has a personal calendar, this event is added to that calendar. If a participant does not have a personal calendar, this form is sent to the participant's Mailbox as a message.
Note
Depending on how your administrator set up your account, events that you create in a group calendar may be added directly to that calendar, or the events may be added to your personal calendar, with copies placed in the group calendar.
Adding events from other calendars
You can copy events from one calendar to another. This can be useful for adding events from group calendars to your personal calendar.
To copy an event to another calendar, drag it from the source calendar to the appropriate date on the target calendar.
Viewing calendar events
As is the case for messages, a calendar event is flagged as unread until you open it or turn the unread flag off.
Opening an event lets you view all its details. You can also see some details in a popup window by hovering your cursor over the event.
If the event includes a mail list as a participant, you can see who belongs to the mail list by selecting it from the Scheduling tab, then choosing Open User Info Form from the shortcut menu.
Updating calendar events
To change details about an event that you created, open it, make your changes, then close the event form.
If you change the start date, the event will move to the new date on the calendar. The event is also moved and reflagged on participants' calendars.
If you delete a participant, the event is removed from that participant's calendar.
Shortcuts
To move an event, you can drag it to the new date. Dragging an event to the Today list is the same as dragging it to today's date on the calendar.
To change the time of an event, you can hover the cursor over it and drag, just as you can in an opened event form.
Changing one occurrence of a repeating event
If you make a change to an event which is one of a series of repeating events, then close the event, you are asked if you want to change all of the repeating events, just the current repetition, or all repetitions starting with the current one.
Deleting calendar events
If you are creating a calendar event and decide you do not want it, you can delete it while it is still open, just as you would an open message.
If you delete an event that you created previously, the event is removed from all participants' calendars.
You can delete one occurrence of a repeating event.
Responding to calendar events
If you are invited to an event, the event is added to your personal calendar. If you see Accept and Decline buttons on the event form, click the appropriate button:
•	Accept accepts the invitation*
•	Accept with Reply accepts the invitation and creates a reply to the event sender
This allows you to ask the sender questions or to make comments.
•	Decline declines the invitation*
•	Decline with Reply declines the invitation and creates a reply to the event sender.
* If the person who invited you is not on your local server (and therefore cannot view the history of the event to check whether you accepted or declined), a message is generated for that person.
The person who invited you will see an icon beside your name on the Scheduling tab. This icon indicates whether you have accepted or declined.
Sending event invitations over the Internet
If you invite someone who has an Internet address (an address that contains @) to participate in your event, the recipient will receive a message with a vCalendar attachment. This attachment can be imported into the recipient's own calendaring application.
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Calendar tasks
Adding calendar tasks
To add a task to a calendar:
1	Open the calendar.
2	Choose File > New > New Task.
Shortcuts
To create a task that starts today, double-click within the blank space in the Today list. To create a task that starts on any other particular day, open the shortcut menu from that day, then choose New Task.
3	Update the basic task information.
4	Update the Reminders tab, if you want to generate reminders, before the start and due dates, for a task with a due date.
If you add reminders to the task, this icon is displayed beside it:
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5	Attach files or add content just as you would for a message, if necessary.
The task is added to your calendar when you close the calendar task form.
Adding tasks from other calendars
You can copy tasks from one calendar to another. This can be useful for adding tasks from group calendars to your personal calendar.
To copy a task to another calendar, drag it from the source calendar to the appropriate date on the target calendar.
Deleting calendar tasks
If you are creating a calendar task and decide you do not want it, you can delete it while it is still open, just as you would an open message.
Viewing calendar tasks
Incomplete tasks remain on the Today list and on all days after they have started.
Overdue tasks are shown in red. Completed tasks have a red line through them.
To see task details, open the task. You can also see some details in a popup window by hovering your cursor over the task.
Updating calendar tasks
To change details about a task, open it, make your changes, then close the task form.
If you change the start date, the task will move to the appropriate date on the calendar.
Shortcut
To move a task, you can drag it to the new start date. Dragging a task to the Today list is the same as dragging it to today's date on the calendar.
Changing calendar task status
To change the status of a task, choose the appropriate status at "Task state" on the task form.
If you choose Completed, today's date appears at "Completed on". You can change this date if necessary by clicking the date to open a popup calendar. If you drag a completed task to another date, the "Completed on" date changes accordingly.
Shortcut
If you do not already have the task open, you can change the task status to Completed by clicking the task icon. Clicking this icon again changes the status back to Not Completed.
Completed tasks drop to the bottom of the Today list.
Top
Creating public calendars
You can create group, resource, and location calendars just as your administrator does.
To create a public calendar:
1	Open the location (for example, a conference) where you want the calendar.
2	Choose File > New, then the appropriate type of calendar.
The new calendar opens.
3	Choose File > Properties (Windows) or Get Info (Mac OS).
4	Type the calendar name at "Name".
5	Type a short description of the calendar at "Subject", if desired.
6	Set calendar properties and permissions.
Note
You can also change permissions for your personal calendar if you want to change the expiry period for items in your calendar, or give other users more or less permission to use your calendar than is normally allowed.
Setting calendar properties and permissions
To specify the properties for a public calendar and give other users permission to use the calendar:
1	Select or open the calendar.
2	Choose Collaborate > Permissions.
3	Update the Permissions form.
Your changes are saved automatically when you close this form.
Reminder
You can access detailed information about calendar permissions by choosing Help > About this Window from the Permissions form. If you require more information on how to set up your calendar permissions, contact your administrator.
Providing information about calendars
You can provide other users with information about a calendar by creating a résumé for it. To do this:
1	Choose Collaborate > Permissions with the calendar open or selected.
2	Click About.
3	Update the Résumé form.
Your changes are saved automatically when you close this form.
Updating calendars' Directory entries
A calendar's Directory entry shows you the calendar name and location. You can update certain calendar information.
To open the Directory entry for a calendar:
1	Choose Collaborate > Permissions with the calendar open or selected.
2	Click Directory info.
3	Update information, if necessary.
To stop this calendar from being listed in the Directory, select "Unlisted". To assign an alias to this calendar, type the name at "Alias".
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