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Before your organization can use FirstClass, you must set up your FirstClass environment. We assume that you have:
•	installed all the FirstClass components that you will require
•	configured the server (this includes adding user licenses and additional connection services as required)
•	planned your FirstClass environment (this includes deciding what gateways you require, what conferences your users will require, and what you want your users to see on their Desktops by default)
•	distributed the FirstClass client to your users.
These tasks are described in the FirstClass Administrator's Guide. This online information describes how to set up the environment that you have planned.
The administrator's Directory
You can search the administrator's Directory for any entry (for example, a user or a conference) and perform common administrative functions on accounts. To open the administrator's Directory, choose Admin > List Directory.
Listing Directory entries
To list all entries in the administrator's Directory, click Search.
You can refine the list before you click Search by:
•	using the "Pattern" field just as regular users do
•	choosing the field you want to match at "Search"
If you choose By User ID, remote names and routes will not appear in the list because they do not have user IDs. If you select By User Group, you must type the group name exactly at "Pattern".
•	selecting the types of objects you want to list.
"Other" includes user groups and mail lists in the list.
Selecting multiple entries
To select a block of continuous entries, click the first one, then Shift-click the last one in the block. To select discontinuous entries, click the first one, then Control-click (Windows) or Command-click (Mac OS) the others. You can combine these selection methods.
Performing multiple searches
You can perform multiple searches and use "push pins" to save the results of each search. 
To perform multiple searches: 
1	Perform the first search. 
2	Click the push pin column at the left beside each result you want to save. 
3	Perform the next search. 
	The results with the push pins will stay and the others will be cleared from the list. 
If the new search results move the push pinned results out of sight, you can click the push pin column heading to bring all push pinned results to the top.
To clear a push pin from a result, click the push pin icon.
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Setting system defaults
The System Profile stores all the basic configuration information for your system. The settings on this form control the basic operation of your FirstClass server and provide system defaults. 
To set system defaults:
1	Choose Admin > System Profile. 
2	Edit the form. 
The form online help and the FirstClass Administrator's Guide will guide you through the basic setup.
3	Click OK. 
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User accounts
You can add as many users as your system is licensed for. You can increase this number by purchasing and installing more user licenses. To purchase more licenses, contact your reseller. 
To add a user account
1	Choose Admin > Add User.
You can also create a new user from the List Directory window.
2	Fill in the User Information form.
3	Click OK.
To edit a user account
1	List and select the user in the administrator's Directory.
2	Click Edit and make any changes to the User Information form.
3	Click OK.
Deleting user accounts
When you delete a user account, any messages sent by the user remain on the server until all links to them expire or are deleted by recipients. 
You can delete user accounts in the following ways:
•	manual deletion
	This is appropriate for a small number of accounts.
1	List and select the user in the administrator's Directory.
2	Click Delete.
•	automatic deletion of inactive accounts (account expiry)
	Expired accounts are deleted during trash collection. Each deletion is logged in the server log file. You cannot use this method for users with the Does Not Expire privilege.
1	Choose Admin > System Profile.
2	Specify how long users can be inactive before their accounts expire at "Inactivity limit before deletion" on the User Limits tab.
The value No Limit means there will be no automatic deletion of inactive accounts.
3	Click OK.
•	deletion using the DEL or DELALL batch administration commands.
	For information on deleting users using batch administration commands, see our online help.
Adding a user group
When you install the FirstClass server, it automatically creates several standard user groups. User groups make your job easier, as you can set privileges, create Model Desktops, or make changes for a group of users rather than individually for each user. The server automatically adds users to these groups as required. For a list of standard user groups and which users belong to them, see the FirstClass Administrator's Guide. 
In addition to the standard user groups, you can create your own user groups to match the structure of your organization.
To add a user group:
1	Open the Groups folder on the administrator's Desktop.
2	Choose Admin > Add > User Group.
3	Type the name you want for this user group at "Group name".
4	Click OK.
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Conferences
A conference is an online forum for user discussion. You can also think of it as a shared Mailbox used as a repository for messages on a particular topic. For more information on conferences, see FirstClass Administrator's Guide. 
To create conferences
1	Open one the General Conferences folder on the administrator's Desktop.
2	Choose File > New > New Conference.
3	Choose File > Properties (Windows) or Get Info (Mac OS) with the new conference selected.
4	Fill in the Info form.
5	Click OK.
Conference groups
Conference groups allow you to assign permissions to several conferences at once the same way user groups allow you to assign privileges to several users at once. There is one standard conference group, All Conferences. Like the All Users group, you should use it to set the standard permissions that will apply to most conferences. Then, use conference groups you create or the individual conference forms to change those permissions.
To create a conference group
1	Open the Groups folder on the administrator's Desktop.
2	Choose Admin > Add > Conference Group.
3	Type the name you want for this conference group at "Group name".
4	Close the Conference Group form.
5	Choose File > Properties (Windows) or Get Info (Mac OS) with the conference group selected.
6	Select "Protected" to prevent the conference group from being deleted by accident.
7	Click OK.
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Calendars
Each user can have only one personal calendar. This calendar is available with the Calendaring privilege. You can set this privilege through a user's User Information form or a user group. A personal calendar is a standard object on the All Users Model Desktop. 
Calendar groups
Calendar groups allow you to set default permissions for all calendars that belong to the group. FirstClass comes with the following standard calendar groups:
•	All Calendars
•	User Calendars
•	Group Calendars
•	Resource Calendars
•	Location Calendars
All calendars of all types belong to the All Calendars group and have that group's permissions applied first. They then belong to the group specific to the type of calendar and the permissions of that group override the All Calendars permissions. These permissions are in turn overridden by the permissions of any group that you create.
To add a calendar group
1	Open the Groups folder on the administrator's Desktop.
2	Choose Admin > Add > Calendar Group.
3	Type the name you want for this calendar group at "Group name".
4	Close the Calendar Group form.
5	Choose File > Properties (Windows) or Get Info (Mac OS) with the calendar group selected.
6	Select "Protected" to prevent the calendar group from being deleted by accident.
7	Click OK.
Users with the Create conferences and Calendaring privileges can create group, resource, and location calendars just as you can. In addition, because it often makes sense to put public calendars inside conferences to which they apply (for example, location calendars for meeting rooms inside a staff conference), users also need the Create subconference permission for conferences inside which they may create calendars.
Allowing users to schedule by period
FirstClass administrators can create an extra "Period" field on the standard Calendar Event form that includes a pulldown menu with predefined period choices. Users can schedule Calendar events using these period choices, set for specific start times and duration. If you are not familiar with customizing forms and distributing them to your users, see FirstClass Designer.
In an education environment, you can create a "Period" field, and have multiple predefined choices in the pulldown list called First period, Second period, Lunch period, and so on. You can assign a start time and a duration to each of these choices. For example, First period can start at 8:00 AM with a duration of one hour. When a user picks First period from the pulldown list, the correct values for the start and end times will be automatically inserted: starts at 8:00 AM and ends at 9:00 AM. 
In a business environment, your predefined entries in the "Period" field might be Morning shift, Afternoon, shift, Night shift, and so on. 
Regardless of your industry, you follow the same procedure. To create a "Period" field:
1	Use FirstClass Designer to open a settings file that contains the New Calendar Event Form (161).
2	Open the New Calendar Event form.
3	Add a static selection field to the 1045 field ID.
4	Add the period selections separated by semicolons.
	The values at "List" of each item of the popup must be in the format HHMMHHMM, where the first HHMM are the hours and minutes of the start time and the second HHMM are the hours and minutes of duration. 
	So, for example, if First period is from 8:00 AM to 9:00AM, and you want the first choice to be None, you would type: 
	None=0;Period 1=08000100;	
5	Save your form changes.
6	Distribute the customized form to your users.
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Public chats
A chat is an online conversation among users who are currently connected to a FirstClass server. FirstClass supports two types of chats: private chats, initiated by users; and public chats, set up and maintained by the administrator. For information on private chats, see our client and web online help. Once the public chat is created, it works just like a private chat.
To create a public chat:
1	Open the conference or folder in which you want to create the chat.
	Note
	Public chats can only be located in a conference or folder. You cannot put a link to a public chat on a Model Desktop or an individual user's Desktop.
2	Choose Admin > Add > Chat File.
3	Choose File > Properties (Windows) or Get Info (Mac OS) with the new public chat selected.
4	Fill in the Info form.
5	Click OK.
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Public mail lists
A public mail list contains the names of users to whom you routinely send mail. 
To create a public mail list:
1	Open the Mail Lists folder on the administrator's Desktop.
2	Choose Admin > Add > Mail List.
3	Fill in the Global Mail List form.
4	Click OK.
To limit who can see the mail list:
1	List the mail list in the administrator's Directory.
2	Open the mail list.
3	Add user and conference groups at "Member of" just as you would address a message.
This makes your mail list visible only in the Directory views of those groups.
4	Click OK.
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Stationery
Stationery is used to prefill certain fields in message forms, such as the "To" field or "Subject" field. For example, you could create a technical support form for your customer support people, where the message is preaddressed to Technical Support and the subject is prefilled as Support Questions. For information on how to create and distribute stationery to your users, see FirstClass Designer.
Top
Setting up users' Desktops
As administrator, it is your job to create the default appearance of your users' Desktops. This includes providing links to container objects (conferences, folders, and calendars) that you want your users to access. The most efficient way to do this is by creating Desktops for groups of users instead of for each individual user separately. FirstClass lets you create default group Desktops through the Model Desktop feature. Model Desktops reduce the effort involved in maintaining your system. Each user group has a Model Desktop that is the basis for the Desktop of each user in the group. 
When you add an icon to a group's Model Desktop, that icon is added to the Desktops of all users who are members of that group. The icon is added in the same location as it appears on the Model Desktop. When you remove an icon from a group's Model Desktop, that icon is removed from the Desktops of all users who are members of that group. For more information on Model Desktops, see the FirstClass Administrator's Guide.
Working with the All Users Model Desktop
The All Users Model Desktop determines the size of the Desktops of all new users you create, and the location of users' Mailboxes. All users have a Mailbox, Address Book, Calendar, Home Page Folder, Bookmarks folder, and Help folder. 
The MailBox icon
The position of the Mailbox icon on the All Users Model Desktop determines the position of the Mailbox on the Desktops of all new users. If you delete the Mailbox icon from the All Users Model Desktop, new users will still get a Mailbox placed in the default location on their Desktop. Do not delete the Mailbox icon.
Creating a Model Desktop
To create a Model Desktop:
1	Open the Groups folder on the administrator's Desktop.
2	Open the user group for which you want to create a Model Desktop.
3	Click Model Desktop on the Group Privileges form.
	The Model Desktop for that group opens.
4	Select an icon from the administrator's account that you want placed on the Model Desktop.
5	Choose Collaborate > Add to Desktop.
	A Desktop link will appear on the administrator's Desktop.
Note
Any icons you want to place on the new Model Desktop must first be on the administrator's Desktop.
6	Drag the Desktop link from the administrator's Desktop to the desired location on the Model Desktop.
Because icons are added to a user's Desktop in exactly the same location as they appear on the Model Desktop, you should choose the location for icons carefully, particularly if users are members of multiple user groups.
7	Choose File > Properties (Windows) or Get Info (Mac OS), with the new Desktop link selected.
8	Fill in the Info form.
9	Click OK.
10	Repeat the previous steps for every icon that you want on this Model Desktop.
11	Close the Model Desktop.
12	Wait for modeling to complete.
Warning		
Do not log off until you are told that modeling is completed.
Deleting icons from Model Desktops
Warning
When you delete an icon from a group's Model Desktop, the icon is deleted from the Desktop of every user in the group who has it, even if the user is a member of another group that still has the icon on its Model Desktop.
To delete an icon from a Model Desktop:
1	Open the Groups folder on the administrator's Desktop.
2	Open the user group from whose Model Desktop you want to remove the icon.
3	Click Model Desktop.
4	if the icon is protected
Select the icon, choose File > Properties (Windows) or Get Info (Mac OS), clear "Protected", then click OK.
5	Select the icon, then choose File > Delete.
6	Rearrange the remaining icons, if necessary.
7	Close the Model Desktop.
8	Wait for modeling to complete.
Warning		
Do not log off until you are told that modeling is completed.
Changing icon properties and locations
FirstClass only remodels a Desktop when you add or remove an icon on the Model Desktop, not when an object is only modified. Both existing and new users' Desktops will reflect this change. To move an icon or change its name or other properties, delete the icon from the Model Desktop, then add it again.
For example, to change the name of the News conference to Hot News, delete the News icon from the Model Desktop, place an icon of the News conference on the Model Desktop again, then change the name of the icon.
Changing the Desktop size and view
You can use Model Desktops to set the size of users' Desktops, and to change their views of container objects (folders, conferences, calendars).
The All Users Model Desktop determines the size of new users' Desktops. After you change the size of the All Users Model Desktop, all new users you add will have the changed Desktop size. Remember, this change will not be reflected on your existing users' Desktops, as FirstClass only updates Model Desktops when you add an icon to or remove an icon from the Model Desktop.
To change the view of container objects for a particular user group, display the Model Desktop for the group, then modify the views for folders and conferences.
You can also add a picture as the default background for users' Desktops.
To apply a background picture to a Model Desktop:
1	Open the All Users Model Desktop.
2	Choose Edit > Preferences.
3	Fill in the "Form background" section of the General tab.
4	Click OK.
Note
Changing the background picture this way will not automatically be reflected on existing users' Desktops. As stated earlier, this is because Desktop modeling does not occur unless you have added or deleted a container object. If you change the default picture for a user group, we recommend  that you add or delete a dummy folder or conference to initiate remodeling for all of the group's users. You can always delete this folder or conference so it does not remain on the group's Desktop.
Two other procedures exist for adding or changing background pictures on a group's Desktop:
•	use batch administration
•	make the change on each individual Desktop.
Model Desktops and multiple groups
When users are in multiple user groups, their Desktops are created by combining the contents of all applicable Model Desktops. If you are going to use multiple user groups to control access to conferences, remember that each Model Desktop dictates the exact location of icons on users' Desktops. Be sure to place icons so that they do not overlap each other.
Creating Desktop links for individual users
You can put a Desktop link on an individual user's Desktop without using a Model Desktop. To do this:
1	Choose the Desktop link that you want to add to the user's Desktop.
2	Choose Collaborate > Add to Desktop.
3	Open the user's Desktop from the administrator's Directory.
4	Drag the Desktop link from the administrator's Desktop to the user's Desktop.
5	Close the user's Desktop.
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Setting up gateways and routes
A gateway is a bridge between your system and another device or system. If you have other FirstClass servers connected to your network, you can set up a gateway to replicate information between them. For an example of how to plan and configure a gateway, see the FirstClass Administrator's Guide. 
Before planning new gateways and routes, you should know how all the servers in your FirstClass network interact with each other. We recommend that you prepare a map of your network.
To create a gateway
1	Open the Gateways folder on the administrator's Desktop.
2	Choose Admin > Add > Gateway Settings.
3	Configure the gateway using the Gateway Settings form.
4	Click OK.
To force a manual gateway connection
1	Open the Gateways folder on the administrator's Desktop.
2	Open the gateway for which you want to force a connection.
3	Click Connect on Close.
4	Click OK to make the gateway log into the remote server.
To set up conference replication
1	Make sure the conference you want to replicate exists with the same name on both servers.
2	Choose Admin > Give Alias with the conference selected.
3	Type the gateway's user ID at the "User ID" field.
4	Click Give Alias.
To set up self-serve replication
1	Open the General Conferences folder on the administrator's Desktop.
2	Choose File > New > New Conference.
3	Choose File > Properties (Windows) or Get Info (Mac OS) with the new conference selected.
4	Type the name you want for this conference (for example, Self-Serve) at "Name".
5	Select "Protected".
6	Click OK.
7	Choose Collaborate > Permissions with the conference still selected.
8	Enter Other Sites at "Who" and choose Contributor at "Access".
This allows gateways to access this conference.
9	Enter All Users at "Who" and accept the default Disallowed at "Access".
This prevents users from contributing to this conference.
10	Add the gateway at "List of subscribers".
11	Close the Permissions form.
12	Make the appropriate conferences available for replication by doing the following for each:
1	Select the conference.
2	Choose Collaborate > Add to Desktop.
3	Drag the resulting link from the administrator's Desktop to the self-serve conference.
4	Give a link to the self-serve conference to all gateways.
13	Notify the administrators of other servers to which your server will replicate.
Send them a message asking them to log in as the gateway account, then drag the links of any conferences they want to replicate from the self-serve conference to their gateway Desktop.
Note
Whenever you create new conferences or delete old ones, update your self-serve conference and keep other administrators informed of the changes.
To configure Directory synchronization
1	Open the Multi-Site Setup folder on the administrator's Desktop.
2	Open Multi-Site Setup in the Multi-Site Setup folder.
3	Fill in the Multisite Setup form.
4	Click OK.
To force an immediate Directory synchronization with a specific gateway
1	Open the Gateways folder on the administrator's Desktop.
2	Open the gateway to the remote server.
3	Click Manual Sync on the Multisite tab.
4	Click Connect on Close to manually force the gateway connection.
5	Click OK.
Directory synchronization begins after the gateway has performed any other necessary tasks, such as message delivery and conference replication.
Routes
When a FirstClass server receives a piece of mail destined for another site, it first determines whether it has a gateway to that site. If it does, it delivers the mail to the gateway. If it has no gateway, it checks to see if it has a route to that site. A route is a pointer to the next gateway on the path to the destination. If it has a route, it forwards the mail to the gateway specified in the route. You can only have a route if you have a gateway to another FirstClass server, which in turn has a gateway or route to the server that is your final destination.
Before you add a route, you must obtain the serial number and site name of the final remote server. This can be obtained from the administrator of the intermediary gateway, or from the administrator of the server to which you are creating the route.
To add a route:
1	Choose Admin > Add > Route.
2	Fill in the Route form.
3	Click OK.
Remote names
If you have gateways and routes to other FirstClass servers, and you do not wish to synchronize your Directory with the other site's Directory, but you want to add selected individuals from other sites to your Directory, add them as remote names.
To add a remote name:
1	Choose Admin > Add > Remote Name.
2	Fill in the Remote Name form.
3	Click OK. 
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