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This document describes basic administration you must perform on a regular basis. For advanced administration, see Advanced administration. For more information about the administrator's tasks, see the FirstClass Administrator's Guide.
Making unread objects open automatically
Sometimes you have messages that you want to make sure users read. To ensure that they do, FirstClass lets you make unread messages, and conferences containing unread messages, open automatically.
Note
To do this, you must have the Set Expiry Privilege and Contributor permissions for the conference in which the message is located.
To make a message open automatically:
1	Select the message.
2	Choose File > Properties (Windows) or Get Info (Mac OS).
3	Select "Auto Open".
4	Click OK.
To make a conference open automatically:
1	Delete the conference icon from the appropriate Model Desktop.
2	Select the original conference, then choose File > Properties (Windows) or Get Info (Mac OS).
3	Select "Auto Open", then click OK.
4	Make a Desktop link of the conference, then drag it to the Model Desktop.
5	Select the Desktop link, then choose File > Properties (Windows) or Get Info (Mac OS).
6	Ensure that "Auto Open" is still selected, then click OK.
7	Close the Model Desktop window.
8	Wait for remodeling to complete.
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Trash collection
Trash collection removes deleted and expired items, expired user accounts, and performs automatic system repairs. The amount of time trash collection takes depends on the size and complexity of your post office. For more information on trash collection, see the FirstClass Administrator's Guide. 
By default, the FirstClass server is set to perform automatic trash collection once a day. You can also force the trash collection task to run immediately.
Note
Users cannot use the Undelete command to recover their deleted files once trash collection has been run. 
Automatic trash collection
Since the trash collection task may slow down your server, you should try to schedule automatic trash collection for off-peak times when there are usually few users online. By default trash collection runs daily at 3:00 AM. 
To change the scheduled time:
1	Choose Admin > System Profile.
2	Change the time at "Trash collection time" on the Timers tab.
3	Click OK.
Note
The server can deliver messages during trash collection, but trash collection cannot be performed on items in use.
Manual trash collection
If you run out of disk space, you must delete unnecessary files. The disk space released as a result of these deletions, however, is not available until you force a trash collection.
To force a trash collection, choose Admin > Control > Trash Collection. 
Since server performance is decreased during trash collection, you should only force a manual trash collection when necessary; it's better to wait for automatic trash collection.
Note
We suggest that you disable logging before starting a manual trash collection, as sessions on slow servers might experience communication link failures and be dropped.
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Sending broadcast messages to all connected users
You can send a broadcast message to every connected user. This message appears automatically on their screens, instead of in their Mailboxes. You might send a broadcast message, for example, if you want users to log off so you can do a backup.
To send a broadcast message:
1	Choose Admin > Broadcast.
2	Type your message (maximum 80 characters).
3	Click Broadcast.
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Logging users off
You can log off all users or selected users.
To log off all users
1	optional
Choose Collaborate > Who's Online to see who is currently logged in.
2	Choose Admin > Control > Logoff All Users.
3	Click OK.
When you log off all users, everyone except yourself and subadministrators are logged off immediately. If you need to log off subadministrators, you must log them off selectively.
To log off selected users
1	Choose Collaborate > Who's Online or Admin > Session Monitor.
2	Select the users to be logged off.
3	Choose Admin > Control > Logoff Selected Users.
When you log off selected users, they are logged off immediately. This can include yourself and subadministrators.
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Disabling logins
Occasionally you might want to temporarily disable logins. Before disabling logins, it is a good idea to warn users with a broadcast message, so that they can save any work in progress.
You can disable logins:
•	for all users
The administrator and subadministrators can still log in. Other users cannot log in until you re-enable all logins by reversing this procedure or restarting the server.
1	Choose Admin > System Profile.
2	Select "Disable all logins" on the Server tab.
3	Click OK. 
•	for a user group 
Users in this group cannot log in until you re-enable at least one access option.
1	Open the Groups folder on the administrator's Desktop.
2	Open the user group for which you want to disable logins.
3	Clear "FirstClass access", "Internet access", "Command line access", and "Voice access" (if applicable) in the Access section.
4	Click OK.
•	through your modems
Modem users trying to connect to a server that is shut down normally get no answer. If you prefer that they get a busy signal, you can take all modems off hook. This is called busying out modems.
1	Shut down your server.
2 	Start FirstClass Tools.
For information on starting FirstClass Tools, see FirstClass Tools Reference in the Online Books folder in online help.
3	Choose File > Busy Out All Modems.
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Shutting down and restarting the server
Some tasks will require you to shut down or restart your server. These tasks can be done from the server console or from the administrator's Desktop. 
The following are the shutdown and restart options available:
•	Fast Shutdown
Logs off all users immediately and shuts down the server.
•	Polite Shutdown
Sends a broadcast message to all users instructing them to log off as the server will be shut down in one minute. Users who do not log off will be logged off automatically when the server shuts down.
•	Restart
Initiates a Fast Shutdown of your FirstClass server, followed by a restart of your server machine. The FirstClass server is not restarted automatically.
To perform these tasks from the server console:
Choose Server and then the appropriate menu command (only Fast Shutdown and Polite Shutdown are available from the server console).
To perform these tasks from the administrator's Desktop:
1	Choose Admin > Control. 
2	Choose the appropriate menu command.
It is recommended that you always warn your users before shutting down your server. You can do this by either initiating a Polite Shutdown or sending a broadcast message informing your users when the server will be shut down.
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Resetting server modems
Most modems are not set up to work with your server when they are initially turned on. When the server starts up, it sends a Reset string to each modem to set it up correctly. The server also sends the Reset string to a modem when a user logs off, or when a session ends for some other reason.
If you turn a modem off and back on again, or otherwise reset it, you must force the server to send these strings again by choosing Admin > Control > Reset Server Modems. The reset command is sent to all modems not actively being used for connections.
If the server does not receive an OK response after 50 attempts to reset a modem, it reports the problem to you by email.
Note
Choosing Reset Server Modems also causes Internet Services to disconnect and reconnect.
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Monitoring system usage
The Server Monitor provides information about how your system is performing by displaying what tasks the server is currently running, the current load on your hardware, and a summary of what has happened since the server was last restarted. To view the Server Monitor, open the Monitors folder on the administrator's Desktop. The Server Monitor also provides information about FirstClass services and mirrored volumes.
The Session Monitor is a real-time online display showing the names of logged-in users and what they are doing. To view the Session Monitor, choose Admin > Session Monitor, or open the Monitors folder on the administrator's Desktop. Some tasks you can perform from this window are logging off users, viewing users' Desktops, or viewing users' résumés.
When you start the FirstClass server, the FirstClass Server console appears on your screen. There are a number of menu items you can use from this console screen. The same menus exist on Windows and Mac OS with the exception of the Edit menu, which is not available on Mac OS. The Help menu has the usual system specific help options. 
For more information on the Server Monitor, Session Monitor, and the FirstClass Server console, see the FirstClass Administrator's Guide.
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Disk use statistics
When FirstClass performs a trash collection, it produces a Disk Usage report. This report records how much hard disk space is used by each of your users. A Disk Usage report is named DiskUse.txt.
You can view a disk use statistics file using FirstClass or a text editor, or import it into a spreadsheet (see your spreadsheet program documentation for details). 
The report contains a one-line entry for each user, with the following information:
•	first column - the user's unique user ID
•	second column - the name of the volume on which the user account is registered
•	third column - the total space
For performance reasons, FirstClass no longer maintains this field. For backward compatibility with log analysis programs, this field remains, but is always zero.
•	fourth column - the total number of files
For performance reasons, FirstClass no longer maintains this field. For backward compatibility with log analysis programs, this field remains, but is always zero.
•	fifth column - the total referenced space
The total size, in kilobytes, of incoming and outgoing messages, documents, and uploaded files in the user's Mailbox and folders.
•	sixth column - the total referenced files
The total number of incoming and outgoing messages, documents, and uploaded files in the user's Mailbox and folders.
•	seventh column - the user's privileges
Special privileges granted to the user. This field can contain one or more of the following:
A - administrator (or subadministrator)
E - edit user information
U - view unlisted
V - view user information.
Viewing a Disk Usage file using FirstClass
To view a Disk Usage report while you are logged into FirstClass:
1	Open the Reports folder on the administrator's Desktop.
2	Open the the Statistics Folder.
3	Open DiskUse.txt.
Viewing a Disk Usage file using a text editor
To view a Disk Usage report when you are not logged into FirstClass:
1	Open the FCPO folder (Windows) or FirstClass Post Office folder (Mac OS), on your hard drive.
2	Open the Stats.dir folder. 
3	Download the DiskUse.txt file to your computer.
4	Open the downloaded copy of DiskUse.txt.
Releasing disk space
In your System Profile, you can configure the minimum free disk space required on each volume on your server. When the amount of free disk space on a volume is less than or equal to this amount, the server refuses to accept messages from users or gateways on that volume.
There are several ways you can free up space:
•	Use the Disk Usage report to identify users who are using excessive space. Ask these users to clean out their Mailboxes.
•	Set disk usage quotas.
•	Look for and delete files with large attachments (remove and delete the attachments before deleting the files).
•	Make sure all aliases of a deleted item are also deleted. The space an item takes up is recovered only when all copies are deleted. Deleting a large file recovers no space unless the alias is also deleted from the sender's Mailbox (and from the Mailboxes of all other recipients).
•	Decrease the expiry period on the System Profile form or on the Permissions forms of your busiest conferences.
•	Delete old statistics and log files. We suggest that you back up these files before you delete them, in case you need to troubleshoot a recurring problem. 
On a Mac OS, the statistics files are located in FirstClass Post Office/Stats.Dir. The log files are located in FirstClass Post Office/LogFiles. 
In Windows, the statistics files are located in FCPO/STATS.DIR. The log files are located in FCPO/LOGFILES.
To recover freed disk space, trash collection must be run after files are deleted. You can force a trash collection immediately, or wait until the next scheduled trash collection takes place.
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User statistics
FirstClass lets you collect selected user activity statistics. By default, each record contains user ID, time, and date fields, plus other fields specific for the record type. A user statistics file is named either yymmdd  or yymmddI where yymmdd is the date the log file was created and 'I' at the end of the date signifies the file is for Internet user statistics only. This file is updated after each trash collection. 
To create customized user statistics reports
1	On the administrator's Desktop, open the Reports folder.
2	Double-click the Statistics Control form.
3	Complete the fields.
	See forms help for an explanation of the fields.
4	In the Journaling control section, select the actions you want to record in the user statistics file (see User activities in the Journaling section).
	The number of actions you select and the activity level on your FirstClass system determines the size of your statistics file.
5	Close the form and save your changes.
To view a user statistics file
1	Open the folder you specified in the "Statistics folder path" field on the Statistics Control form.
2	Open any of the files that you wish to view.
	The files open in SimpleText (Mac OS) or Notepad (Windows).
The user statistics file format
A user statistics file consist of fields that are separated by the delimiter you specified on the Statistics Control form.
These are the common field types that can be applied to each record:
•	the user ID (userID) of the user performing the action
•	the date (date) the action was performed, in the format ddmmyy
•	the time (time) the action was performed, in the format hh:mm:ss am|pm
•	the unique file ID (fileID) of the file or folder being processed. 
FirstClass uses file IDs to access the files and folders on a volume
•	the client ID (clientID)of the user performing the action. 
FirstClass assigns a unique client ID to each user. The client ID is never assigned to another user.
•	the message ID (messageID) of the message being processed
	Every message in FirstClass has a unique message ID.
•	the name of the object (obj name) being processed
•	the type of object (obj type) being processed 
•	the parent object (parent obj) of the object being processed
	An example of this is a conference item's parent object would be the conference.
•	the file size (in bytes) (file size) of the object being processed.
User activities in the Journaling section
•	AddUser
Action that generates this record:
A user is added with the Admin > Add New User command.
Checkboxes that generate this record:
Add, Del, Change User
Record format:
AddUser, user ID, date, time, new user ID, last name, first name, initial, client ID
•	ApplyModel
Action that generates this record:
A user group's Model Desktop is updated and the remodel is applied to its members.
Checkboxes that generate this record:
Modeling
Record format:
ApplyModel, userID, date, time, priv group name
•	Approve
Action that generates this record:
A user approves or unapproves an object.
Checkboxes that generate this record:
Approve Items
Record format:
Approve, userID, date, time, approved, conference, messageID, fileID
where approved can be zero (approved) or 1 (unapproved)
•	Attach
Action that generates this record:
A file is successfully attached to a message.
Checkboxes that generate this record:
Upload/Attach
Record format:
Attach, userID, date, time, filename, file size, messageID
•	AutoReg
Action that generates this record:
A user who does not already have an account autoregisters.
Checkboxes that generate this record:
Session (login/logout)
Record format:
AutoReg, null, date, time, userID, last name, first name, initial, clientID
Because the user ID has not yet been defined, this field is left blank.
•	ChangeUser
Action that generates this record:
A user information form is changed.
Checkboxes that generate this record:
Add/Del/Change user
Record format:
ChangeUser, userID, date, time, changed userID
•	Close
Action that generates this record:
An object (such as a message, folder, or conference) is closed.
Checkboxes that generate this record:
Object open
Record format:
Close, userID, date, time, type, name, parent obj
•	CommLinkFail
Action that generates this record:
A client/server link is broken. A logout record is generated at the same time. Use this record to identify modem or TCP problems.
Checkboxes that generate this record:
Comm link failure, Modem carrier loss
Record format:
CommLinkFail, userID, date, time, session number
•	ConfDelivery
Action that generates this record:
An item is sent to a conference.
Checkboxes that generate this record:
Delivery to conference
Record format:
ConfDelivery, server, date, time, conference name, from name, subject, messageID
where conference name is the name of the conference to which the item was delivered, and from name is the name of the system on which the item originated (for items received from a gateway)
•	ConfItemDel
Action that generates this record:
An item is deleted from a conference.
Checkboxes that generate this record:
Conference item delete
Record format:
ConfItemDel, userID, date, time, subject, messageID, fileID
•	ConfPermissions
Action that generates this record:
A user views the permissions of a conference.
Checkboxes that generate this record:
Conf. permissions, Edit conf. permissions
Record format:
ConfPermissions, userID, date, time, obj name, fileID
•	ConfSubscribe
Action that generates this record:
A user is granted a subscription to a conference.
Checkboxes that generate this record:
Conference subscribe
Record format:
ConfSubscribe, userID, date, time, obj type, obj name, subscribed user ID
•	Control
Action that generates this record:
A Control menu command is chosen from the Admin menu.
Checkboxes that generate this record:
Control/Sys/Broadcast
Record format:
Control, userID, date, time, control command, success
where success can have the value zero (successful) or Error 1030 (Access Denied)
•	Create
Action that generates this record:
An object (such as a message, conference, or folder) is created.
Checkboxes that generate this record:
Message create, Conf. create/delete
Record format:
Create, userID, date, time, obj type, parent obj, fileID
•	DeleteUser
Action that generates this record:
A user account is deleted with the Admin > Delete User command.
Checkboxes that generate this record:
Add/Del/Change user
Record format:
DeleteUser, userID, date, time, deleted userID
•	Directory
Action that generates this record:
A user searches the Directory.
Checkboxes that generate this record:
Directory search
Record format:
Directory, userID, date, time, pattern
•	Download
Action that generates this record:
A user downloads, from a conference, a file that is not attached to a message.
Checkboxes that generate this record:
Download/Save attach
Record format:
Download, userID, date, time, filename, messageID, fileID
•	GetInfo
Action that generates this record:
A user chooses File > Get Info or Properties to display information about an object.
Checkboxes that generate this record:
Get info
Record format:
GetInfo, userID, date, time, obj name, fileID
•	History
Action that generates this record:
A user displays the history of a message.
Checkboxes that generate this record:
View history
Record format:
History, userID, date, time, subject, messageID, fileID
•	Login
Action that generates this record:
A user logs in.
Checkboxes that generate this record:
Session (login/logout), Gateways
Record format:
Login, userID, date, time, interface, platform, link type, session #, modem speed, client version, protocol, network address
where
interface can be GUI, CLUI, or Gateway
platform can be Mac OS, Windows, DOS, or VT100
link type can be Serial or LAN
client version can be 5500 (version 5.5) and so on
protocol can be AppleTalk, IPX, TCP/IP, or Local
Network address can be:
•	network.node.socket in decimal (for example, 2.56.235) (AppleTalk)
•	network.node.socket in hexadecimal (for example, 000000D3.00-C2-EE-00-01-34.4032) (IPX)
•	IP address in dot format (for example, 198.133.37.10) (TCP/IP)
•	Logout
Action that generates this record:
The server terminates a session, either because the user has logged off or the user's time has expired.
Checkboxes that generate this record:
Session (login/logout)
Record format:
Logout, userID, date, time, seconds since login
•	MsgDelete
Action that generates this record:
A user deletes a message from his or her Mailbox.
Checkboxes that generate this record:
Message delete
Record format:
MsgDelete, userID, date, time, subject, messageID, fileID
•	MsgDelivery
Action that generates this record:
A message is delivered to a gateway or a user's Mailbox.
Checkboxes that generate this record:
Delivery to Mailbox
Record format:
MsgDelivery, server, date, time, to, from, subject, messageID
•	MsgForward
Action that generates this record:
A user forwards a message. Autoforwarded messages do not generate MsgForward records.
Checkboxes that generate this record:
Message forward
Record format:
MsgForward, userID, date, time, subject, messageID, fileID
•	MsgReply
Action that generates this record:
A user replies to a message. Autoreplied messages do not generate MsgReply records.
Checkboxes that generate this record:
Message reply
Record format:
MsgReply, userID, date, time, subject, messageID, fileID
•	Open
Action that generates this record:
An object (such as a message, conference, or folder) is opened.
Checkboxes that generate this record:
object open, Private chatting, Public chatting
Record format:
Open, userID, date, time, obj type, obj name, fileID
•	OpenDeskTop
Action that generates this record:
The administrator opens a user's Desktop.
Checkboxes that generate this record:
Open user Desktop
Record format:
OpenDeskTop, userID, date, time, opened userID
•	Password
Action that generates this record:
A user tries to change his or her password.
Checkboxes that generate this record:
Password change
Record format:
Password, userID, date, time, success
where success can have the value 1030 (Access Denied), 5 (Password Incorrect), or 6 (Successfully Changed)
•	Résumés
Action that generates this record:
A user looks at a résumé or user information form.
Checkboxes that generate this record:
View résumés, View conference info
Record format:
Résumé, userID, date, time, whose résumé, clientID, type
where type can be zero (résumé) or 1 (user information form)
•	SaveAttach
Action that generates this record:
A user saves a file attached to a message.
Checkboxes that generate this record:
Download/Save attach
Record format:
SaveAttach, userID, date, time, attachment name, file size, messageID
•	Search
Action that generates this record:
A user performs a search.
Checkboxes that generate this record:
Searching
Record format:
Search, userID, date, time, parent obj, search string, flags, number of hits, duration in seconds
where flags indicates the checkboxes selected on the search form
•	Upload
Action that generates this record:
A user uploads, to a conference, a file that is not attached to a message.
Checkboxes that generate this record:
Upload/Attach
Record format:
Upload, userID, date, time, filename, file size, fileID
•	WhosOnline
Action that generates this record:
A user chooses Collaborate > Who's Online.
Checkboxes that generate this record:
Who's online
Record format:
WhosOnline, userID, date, time, search pattern
where search pattern is always empty
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Server statistics
The server statistics file (Stats.txt) is a cumulative summary of all server events that have occurred since the server was first installed. This file is updated after each trash collection. 
You can view a server statistics file using FirstClass or a text editor (see Disk use statistics), or import it into a spreadsheet (see spreadsheet program documentation for details).
The server statistics file is presented in standard, comma-delimited format, and contains the following information:
Remote user statistics
•	Total Logins - number of logins
•	Total Opens - number of windows opened
•	Total Closes - number of windows closed
•	Total Creates - number of messages and files created
•	Total Submits - number of messages sent
•	Total DirSearches - number of times the Directory was searched
•	Total Timeouts - number of sessions that ended because the daily time limit was exceeded
•	Total Failed UIs - number of sessions that ended because of link failures
•	Bytes Uploaded - number of bytes transferred to the server (uploaded files and attachments)
•	Bytes Downloaded - number of bytes transferred from the server (downloaded files and attachments)
•	Total Connect - total time all users were connected
Network user statistics
The same statistics types for regular users as described for remote users. 
CLUI statistics
The same statistics types for terminal, terminal emulation, and Telnet users as described for remote users. 
Server statistics
Server totals:
•	Total Deliveries - number of messages delivered
•	Recoveries - number of server recoveries (from power failures, and so on)
•	Users Added - number of user accounts added
•	Users Deleted - number of user accounts deleted
•	Rejected Sessions - number of times users could not connect because all sessions were in use. 
	If this number is high, you might consider purchasing additional sessions.
•	Auto-registers - number of autoregistrations
•	Write Protects - number of times the server entered write-protect mode because of a lack of disk space or an excessive number of files. 
	If this number is high, consider moving your FirstClass system to a volume with a larger storage capacity.
Resetting server statistics
To reset server statistics counters, delete the Stats.txt file.
Deleting server statistics files
You should delete statistics files regularly to maintain disk space availability. However, we suggest you back up these files before deleting them in case you need them later to troubleshoot an ongoing problem. 
Reminder
Do not delete a statistics file unless you wish to reset the server statistics counters.
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Daily log files
FirstClass creates a log file of the console activities for each day that the server is active. Log files are named yymmdd, where yymmdd signifies the date the log file was created. In Windows, the extension .txt is added to this name. In Mac OS, there is no extension. This file is updated after each trash collection.
To open a log file while logged into FirstClass
1	Open Reports > Log Files on the administrator's Desktop.
2	Open the log file for the appropriate date.
The report opens in Notepad (Windows) or SimpleText (Mac OS).
To open a log file while logged off of FirstClass
1	Open the FCPO folder (Windows) or FirstClass Post Office folder (Mac OS).
2	Open the Logfiles folder.
3	Open the log file for the appropriate date.
The report opens in SimpleText (Mac OS) or Notepad (Windows).
Deleting log files
You should delete server log files regularly to maintain disk space availability. We suggest that you back up these files before deleting them in case you need them later to troubleshoot an ongoing problem.
Note
If you don't want to write the console logs to file, clear this option on your server console window or delete the Logfiles folder from your hard drive. Never delete the Logfiles folder off the administrator's Desktop.
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Setting the Internet Services debugging file
The Internet Services Config folder, located in the same folder as the Internet Services executable, contains a file called InetSvcs.cf. This file contains a list of Internet Services debugging categories and their respective logging levels. Setting debugging levels in this file will cause Internet Services to display debugging information on its console upon startup. These same debugging options can be set from the Diagnostics > Logging menu on the Internet Services console, although these settings are not saved and will be reset the next time Internet Services is started. For information on the Internet Services console menus, see the FirstClass Internet Services Administrator's Guide.
Debugging categories
Note
In this document, the debugging categories are presented in this format:
	FirstClass 6 Internet Services console pulldown selection 
	Name in the InetSvcs.cf file - Description
The debugging categories located in the InetSvcs.cf file are as follows:
Internet Services
DBG_InetSvc - Logging related to the handling of accepting and distributing incoming connections.
Configuration
DBG_InetCfg - Logs the loading and parsing of configuration data.
DNS Resolver
DBG_Resolver - Logging related to the domain name resolver.
Name Translation
DBG_FCNmTrn - Logging related to the parsing and translation of email addresses.
Mail Encoding
DBG_IMRFCe - Logging related to the encoding of Internet messages.
Mail Decoding
DBG_IMRFCd - Logging related to the decoding of Internet messages.
MIME Decoding
DBF_IMMIMEin - Logging related to the decoding of incoming MIME messages.
Server to FC Connections
DBG_InetCli - Logging related to FCP communication between Internet Services and the FirstClass server for client and Directory services (POP3, FTP, HTTP, LDAP, and Finger).
Finger Server
DBG_ICFngr - Logging related to the Finger protocol.
LDAP Server
DBG_ICLDAP - General logging related to the LDAP protocol.
LDAP Messages
DBG_LDAPMsg - Logging related to the constructing of responses for the LDAP protocol.
POP3 Server
DBG_ICPOP3 - Logging related to the POP3 (client) protocol.
IMAP4 Server
DBG_IMAP4 - Logging related to the IMAP4 protocol.
HTTP Server
DBG_ICHTTP - Logging related to the HTTP protocol.
HTTP Scripting
Logging related to HTTP scripting (IS Script).
FTP Server
DBG_ICFTP - Logging related to the FTP protocol.
Gateway Monitor 
DBG_GWSrvr - Logging related to FCP communication between Internet Services incoming message protocols and the FirstClass server.
SMTP Connection	
DBG_SMTPCln - Queuing of outbound SMTP messages.
SMTP Message
DBG_SMTPMsg - Delivery of outbound SMTP messages.
SMTP Server	
DBG_SMTPCon - Reception of incoming SMTP messages.
NNTP Client Connection
DBG_NNTPGCl - Queuing of outbound NNTP messages.
NNTP Client Message
DBG_NNTPGCM - Delivery of outbound NNTP messages.
NNTP Server
DBG_NNTPCon - Reception of incoming NNTP messages.
POP3 Client
DBG_POP3Cln - Scheduling collection of inbound POP3 messages (POP3 "sucker").
POP3 Client Message
DBG_POP3Msg - Reception of inbound POP3 messages (POP3 "sucker").
Task List	
DBG_TaskList - Reports about changes in Internet Services task states.
Logging levels
Each category is set to a logging level between 0 and  >5. In general, these levels are:
0 - none
1 - connection messages about connecting and disconnecting
2 - session messages about the progress of the request
3 - protocol messages showing communication at the protocol level
4 -"Verbose" debugging information
5 -"Very verbose" debugging information
>5 - will severely impact performance and generate huge log files (set only at Centrinity's request).
Note
We recommend that logging levels stay at or below 2 unless more information is needed to identify a problem. If this is the case, only the specific debugging categories relating to the problem should be changed or the logging will affect the performance of Internet Services.  
Logging to disk
You can enable cross-platform logging to disk by adding the following lines to the 'InetSvcs.cf' file:
[Debug]
Debug = 1
This file, InetSvcs.log (Windows) and Internet Services.log (Mac OS), which resides in the same folder as FirstClass server, is overwritten each time Internet Services is launched. You can open this file in any word processing application.
Task List
The Internet Services console has a menu item named Task List that can be accessed from the Diagnostics pulldown menu. The Task List can be very helpful in correlating log information and can be thought of as a snapshot of what can be seen with DBG_TaskList set to 5. Task List information is most useful in tracking down situations where Internet Services stops processing a particular protocol or connection.
The Task List itself starts with a number in brackets, which is the task ID of the item in question. This number can have a character before it indicating the task's kernel state, the most significant being "S" which means waiting for a semaphore. What follows the task ID is the task's name, which correlates with the DBG_xxxx items mentioned above, but with the DBG_ part dropped. The state of the task is then displayed as two numbers (with commas separating them) followed by a text description of the state. Here are a couple of examples:
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